$re = '/^([0-9]+)(,\s?[0-9]+)*,?\s?$/m';
$str = '34423, 234324, 324234, 2343423,3424324,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);