$re = '/^(\s)(http[s]?)(:\/\/)(\w{1,})(.\w{2,5})(.\w{2,5})?((\/))()?$/';
$str = ' http://localhost.com/link';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);