re = /[aeiou]|[kstpgzdnhpmr][aeiou]|(?:sh|ch|j|ts|f|y|w)(?:y[auo]|[aeiou])|nn|([a-z])\1/m
str = 'kka'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end