re = /([\x{0060}]+)(\x{005C}\x{0060}|.*?)([\x{0060}]+)/m
str = '!pybot ```print("passionbaby")```'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end