#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Z0-9-_]+).txt:\s?\s?([A-Z0-9-_:]+)\s+(\d+:\d+)|([A-Z0-9-_]+).txt:\s+(\w{6})\s+(\d+:\d+)"
Local $sString = "RTARSPO0302.txt:MVNO_AMERICANET 26615:20891087 " & @CRLF & _
"RTARSPO0302.txt: import 26615:30150 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt: import 26615:30200 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt:RAN_SHARING_OI 26615:20302087 " & @CRLF & _
"RTARSPO0302.txt: import 26615:30200 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt: import 26615:30206 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt: import 26615:30301 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt: import 26615:30320 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt: export 26615:30301 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt: export 26615:303027 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt:TIMGPRS 26615:20203087 " & @CRLF & _
"RTARSPO0302.txt: import 26615:30200 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt: import 26615:30301 IPV4 Unicast " & @CRLF & _
"RTARSPO0302.txt: export 26615:30200 IPV4 Unicast " & @CRLF & _
"RTARTSA0101.txt:DCN 26615:20705093 " & @CRLF & _
"RTARTSA0101.txt: import 26615:30700 IPV4 Unicast " & @CRLF & _
"RTARTSA0101.txt: export 26615:30700 IPV4 Unicast " & @CRLF & _
"RTARTSA0101.txt:RAN_SHARING_OI 26615:20301093 " & @CRLF & _
"RTARTSA0101.txt: import 26615:30301 IPV4 Unicast " & @CRLF & _
"RTARTSA0101.txt: export 26615:30301 IPV4 Unicast " & @CRLF & _
"R"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")