$re = '/([0-9]+)[\s]*\°(C|F*)/m';
$str = '9999°F';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);