package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)=([^\s]+)`)
var str = `metadata=1.2 name=stone:supershare UUID=eff4e7bc:47aea5cf:0f0560f0:2de38475`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}