$re = '/(?:\\\\)+(\d{16}|\d{10})/';
$str = 'i:0#.w|unit\\1234567890121212.gov';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);