#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)<a[^>]*href="(?<url>[^"]*(?<=\?|&)o=(?<number>\d+)[^"]*)"[^>]*>\s*last"
Local $sString = "<div class="listing_thumbs_resultcontainer">" & @CRLF & _
" " & @CRLF & _
" <span class="FloatLeft nav-next-btn">" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=1&q=nike air&th=1" title="Go to first page">« First</a>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" <span class="nav-next-btn nohistory marginLeft">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=18&q=nike air&th=1" title="Go to previous page">" & @CRLF & _
" ‹ Previous" & @CRLF & _
" </a>" & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=1&q=nike air&th=1" title="Page 1 of 29">1</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=2&q=nike air&th=1" title="Page 2 of 29">2</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=3&q=nike air&th=1" title="Page 3 of 29">3</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=4&q=nike air&th=1" title="Page 4 of 29">4</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=5&q=nike air&th=1" title="Page 5 of 29">5</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=6&q=nike air&th=1" title="Page 6 of 29">6</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=7&q=nike air&th=1" title="Page 7 of 29">7</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=8&q=nike air&th=1" title="Page 8 of 29">8</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=9&q=nike air&th=1" title="Page 9 of 29">9</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=10&q=nike air&th=1" title="Page 10 of 29">10</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=11&q=nike air&th=1" title="Page 11 of 29">11</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=12&q=nike air&th=1" title="Page 12 of 29">12</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=13&q=nike air&th=1" title="Page 13 of 29">13</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=14&q=nike air&th=1" title="Page 14 of 29">14</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=15&q=nike air&th=1" title="Page 15 of 29">15</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=16&q=nike air&th=1" title="Page 16 of 29">16</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=17&q=nike air&th=1" title="Page 17 of 29">17</a>" & @CRLF & _
" </span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=18&q=nike air&th=1" title="Page 18 of 29">18</a>" & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
" <span class="nav-active"><strong>19</strong></span>" & @CRLF & _
" <span class="non-active nohistory">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=20&q=nike air&th=1" title="Page 20 of 29">20</a>" & @CRLF & _
" </span" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
" <span class="nav-next-btn nohistory FloatRight">" & @CRLF & _
" " & @CRLF & _
" <span class="nav-next-btn nohistory marginRight">" & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=20&q=nike air&th=1" title="Go to next page">" & @CRLF & _
" Next ›" & @CRLF & _
" </a>" & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <a href="http://www.mudah.my/Malaysia/nike+air-for-sale?o=29&q=nike air&th=1" title="Go to last page">" & @CRLF & _
" Last »" & @CRLF & _
" </a>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" </span> " & @CRLF & _
" " & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")