re = /((\u00a9|\u00ae|[\u2000-\u3300]|\ud83c[\ud000-\udfff]|\ud83d[\ud000-\udfff]|\ud83e[\ud000-\udfff]\s?)+)/m
str = '🧜♀️'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result