package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$`)
var str = `ff:ff:00-ff:ff:fa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}