$re = '/((\d{4}|[a-zA-Z0-9]{1}[0-9]{1})([-][0-9]{1,5}))/';
$str = 'C1-2015-13175';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);