const regex = /^ # begin
\s*# some empty spaces
(?:
\+? # + symbol
\d{1,2} # country code
\s*
(?(?=\)) # if followed by parens
| # then dash not allowed
-? # else optional dash
)
)? #prefix like +380
\s*
(?:
(?P<leftparen>\()? # optional left paren
\s*
0\d\d
\s*
(?(leftparen)\)|) # right paren if and only if left paren
)? # operator code, starting with 0, optinally in parentheses
(?(?<=\)) # if preceded by parens
\s*| # then dash not allowed
\s*-?\s* # else optional dash
)
(?:
\d |
(?<=
\d
)
(?(sep)
(?P=sep)|
(?P<sep>[\-\/\ ])
)
(?=
\d
)
){5,13}
\s*# some empty spaces
$ # end
#\d\d\d (?P<separator>-?) \d\d (?P=separator) \d\d $/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ # begin
\\s*# some empty spaces
(?:
\\+? # + symbol
\\d{1,2} # country code
\\s*
(?(?=\\)) # if followed by parens
| # then dash not allowed
-? # else optional dash
)
)? #prefix like +380
\\s*
(?:
(?P<leftparen>\\()? # optional left paren
\\s*
0\\d\\d
\\s*
(?(leftparen)\\)|) # right paren if and only if left paren
)? # operator code, starting with 0, optinally in parentheses
(?(?<=\\)) # if preceded by parens
\\s*| # then dash not allowed
\\s*-?\\s* # else optional dash
)
(?:
\\d |
(?<=
\\d
)
(?(sep)
(?P=sep)|
(?P<sep>[\\-\\\/\\ ])
)
(?=
\\d
)
){5,13}
\\s*# some empty spaces
$ # end
#\\d\\d\\d (?P<separator>-?) \\d\\d (?P=separator) \\d\\d $', 'mg')
const str = `SHOULD MATCH:
5344654
5344654
534-46-54
17189280121
+19173010176
(095)789-58-75
(095) 789-58-75
0957895875
917 229 2897
+38 (095) 5344654
53-475-34
555-1-333
1-333-484
888-333-4
(094)999-22-44
38-095-432-43-34
095-432-43-34
123456
53465
SHOULD NOT MATCH:
1
-1234
38-(095)-432-43-34
534-46/54
(094)999/22-44
1234--567
(345)5345654
(0955344654
095)5345654
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}