import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Audit (?P<audit_outcome>Success|Failure),(?P<log_date>.*)\\s+(?P<log_time>.*),Microsoft-Windows-Security-Auditing,(?P<event_id>\\d+),(?P<category>.*),(?P<event_message>.*)\\s+Subject:\\s+Security ID:\\s+(?P<subject_security_id>.*)\\s+Account Name:\\s+(?P<subject_account_name>.*)\\s+Account Domain:\\s+(?P<subject_account_domain>.*)\\s+Logon ID:\\s+(?P<subject_logon_id>.*)\\s+Process Information:\\s+Process ID:\\s+(?P<PI_process_id>.*)\\s+Name:\\s+(?P<PI_name>.*)\\s+Previous Time:\\s+(?P<previous_time>.*)\\s+New Time:\\s+(?P<new_time>.*)\\s+(?P<audit_message>.*)";
final String string = "Audit Success,29/08/2017 09:42:50,Microsoft-Windows-Security-Auditing,4616,Security State Change,\"The system time was changed.\n\n"
+ "Subject:\n"
+ " Security ID: LOCAL SERVICE\n"
+ " Account Name: LOCAL SERVICE\n"
+ " Account Domain: NT AUTHORITY\n"
+ " Logon ID: 0x3E5\n\n"
+ "Process Information:\n"
+ " Process ID: 0x3e8\n"
+ " Name: C:\\Windows\\System32\\svchost.exe\n\n"
+ "Previous Time: 2017-08-29T01:42:49.858143700Z\n"
+ "New Time: 2017-08-29T01:42:49.520000000Z\n\n"
+ "This event is generated when the system time is changed. It is normal for the Windows Time Service, which runs with System privilege, to change the system time on a regular basis. Other system time changes may be indicative of attempts to tamper with the computer.\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}