re = /class='media-heading'>(.+?)streams.+\n.+?>(.+?),.+?(.+?) /m
str = '
<html>
<head>
<title>NCAAF Streams | CFBStreams Reddit - CrackStreams</title>
<meta name="keywords" content="live cfb Streams, cfbstreams reddit, watch college football streams, cfb stream, football score, cfb video, cfb online, cfb streams reddit, cfbstreams reddit">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="description" content="Watch NCAAF CFB streams with the best HD videos on the net for free - CFBStreams Reddit">
<meta property="og:title" content="CFB Streams | CFBStreams - CrackStreams" />
<meta property="og:description" content="Watch NCAAF CFB streams with the best HD videos on the net for free - CFBStreams Reddit" />
<meta property="og:site_name" content="Crackstreams - CFB Streams" />
<link rel="canonical" href="http://crackstreams.com/cfbstreams/">
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-133177581-1"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag(\'js\', new Date());
gtag(\'config\', \'UA-133177581-1\');
</script>
<link rel="stylesheet" href="/bootstrap3.min.css" media="screen">
<script src="/jquery.min.js"></script>
<script async src="/bootstrap.min.js"></script>
</head>
<body>
<nav class="navbar navbar-default">
<div class="container">
<div class="navbar-header">
<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="navbar-brand" href="/">Crackstreams</a>
</div>
<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
<ul class="nav navbar-nav">
<li><a href="/nbastreams/">NBA streams</a></li>
<li><a href="/nflstreams/">NFL streams</a></li>
<li><a href="/cfbstreams/">NCAAF streams</a></li>
<li><a href="/mmastreams/">MMA/UFC streams</a></li>
<li><a href="/boxingstreams/">Boxing streams</a></li>
</ul>
</div>
</div>
</nav>
<div class="container">
<div class="row">
<div class="col-xs-12 text-center">
</div>
<div class="col-xs-12 col-md-8 col-sm-12">
<div class=\'clearfix\'><h1>NCAAF Live Streams and Schedule</h1><hr></div>
<a href=\'/cfbstreams/26/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Arizona State at #18 Michigan State CFB streams live</h4>
<p>Sept 14th 2019, 4:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/27/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>#19 Iowa at Iowa State CFB streams live</h4>
<p>Sept 14th 2019, 4:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/28/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Southeastern Louisiana at Ole Miss CFB streams live</h4>
<p>Sept 14th 2019, 4:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/29/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Colorado State at Arkansas CFB streams live</h4>
<p>Sept 14th 2019, 4:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/30/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Bethune-Cookman at Miami CFB streams live</h4>
<p>Sept 14th 2019, 4:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/31/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Louisiana Tech at Bowling Green CFB streams live</h4>
<p>Sept 14th 2019, 5:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/32/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Idaho at Wyoming CFB streams live</h4>
<p>Sept 14th 2019, 5:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/33/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Buffalo at Liberty CFB streams live</h4>
<p>Sept 14th 2019, 6:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/34/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>South Carolina State at South Florida CFB streams live</h4>
<p>Sept 14th 2019, 6:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/35/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>UMass at Charlotte CFB streams live</h4>
<p>Sept 14th 2019, 6:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/36/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Southern Mississippi at Troy CFB streams live</h4>
<p>Sept 14th 2019, 6:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/37/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Kent State at #8 Auburn CFB streams live</h4>
<p>Sept 14th 2019, 7:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/38/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>#9 Florida at Kentucky CFB streams live</h4>
<p>Sept 14th 2019, 7:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/39/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Lamar at #16 Texas A&M CFB streams live</h4>
<p>Sept 14th 2019, 7:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/40/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>New Hampshire at Florida International CFB streams live</h4>
<p>Sept 14th 2019, 7:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/41/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Texas State at SMU CFB streams live</h4>
<p>Sept 14th 2019, 7:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/42/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Weber State at Nevada CFB streams live</h4>
<p>Sept 14th 2019, 7:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/43/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Georgia State at Western Michigan CFB streams live</h4>
<p>Sept 14th 2019, 7:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/44/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Murray State at Toledo CFB streams live</h4>
<p>Sept 14th 2019, 7:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/45/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>#1 Clemson at Syracuse CFB streams live</h4>
<p>Sept 14th 2019, 7:30 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/46/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Northwestern State at #4 LSU CFB streams live</h4>
<p>Sept 14th 2019, 7:30 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/47/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Hawai\'i at #23 Washington CFB streams live</h4>
<p>Sept 14th 2019, 7:30 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/48/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Florida State at #25 Virginia CFB streams live</h4>
<p>Sept 14th 2019, 7:30 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/49/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>TCU at Purdue CFB streams live</h4>
<p>Sept 14th 2019, 7:30 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/50/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Southeast Missouri State at Missouri CFB streams live</h4>
<p>Sept 14th 2019, 7:30 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/51/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Texas Southern at Louisiana CFB streams live</h4>
<p>Sept 14th 2019, 7:30 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/52/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>#5 Oklahoma at UCLA CFB streams live</h4>
<p>Sept 14th 2019, 8:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/53/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>#12 Texas vs Rice CFB streams live</h4>
<p>Sept 14th 2019, 8:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/54/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Missouri State at Tulane CFB streams live</h4>
<p>Sept 14th 2019, 8:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/55/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Northern Illinois at Nebraska CFB streams live</h4>
<p>Sept 14th 2019, 8:00 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/56/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Portland State at #22 Boise State CFB streams live</h4>
<p>Sept 14th 2019, 10:15 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/57/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Texas Tech at Arizona CFB streams live</h4>
<p>Sept 14th 2019, 10:30 PM ET</p>
</div>
</div></a>
<a href=\'/cfbstreams/58/\' class=\'btn btn-default btn-lg btn-block\'><div class=\'media\'>
<div class=\'media-left\'>
<img src=\'/images/ncaafz.png\' class=\'media-object\'>
</div>
<div class=\'media-body\'>
<h4 class=\'media-heading\'>Montana at #15 Oregon CFB streams live</h4>
<p>Sept 14th 2019, 10:45 PM ET</p>
</div>
</div></a>
</div>
<div class="col-xs-12 col-sm-12 col-md-4">
<div class="text-center">
<br/><br/>
</div>
<h2>Welcome to Crackstreams</h2>
<h4>Links are updated <b>ONE</b> day <b>BEFORE</b> the event. We offer NBA streams, NFL streams, MMA streams, UFC streams and Boxing streams. <br/><br/>
You can find us on reddit: r/mmastreams/, r/nbastreams, r/nflstreams, r/boxingstreams <br/>
<br/>
Please join our discord: <a href="https://discord.gg/xfScAtn">Discord Server</a>
<br/>
<br/>
</h4>
</div>
</div>
</div>
<hr>
<h2><b>How can I watch Free NCAAF Streams?</b></h2>
<h4>On this page you can see a list of events. Everything is listed by date and time. Scroll down the page and choose what you want to see and click on the Watch Now button. A new page opens on your browser with a screen. Simply click the play icon in the middle of the screen, then wait a second or two for the video to load. After a minute a chat will also open and you can talk with other NCAAF lovers or you can close the chat at any time. The screen can be maximized in the bottom right corner. Whatever device you watch on, whatever the size of the screen or wherever you are, we promise you great HD quality every time. And remember, you can click on the menu icon on the top right of the page and choose a category for more great live HD sport streams.</h4>
<center>
<br/>
<h4>
<b>Crackstreams will provide free live streaming:</b><br/><br/>
<li><a href="/nbastreams/">NBAstreams</a></li>
<li><a href="/nflstreams/">NFLstreams</a></li>
<li><a href="/cfbstreams/">CFBstreams</a></li>
<li><a href="/mmastreams/">MMAstreams</a></li>
<li><a href="/boxingstreams/">Boxingstreams</a></li>
<li><a href="/mmastreams/">UFC streams</a></li>
</center></h4>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end