#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s(\w*)Command\.Register\((([\S]*,([^;\n\r])*)+)typeof\((.*)Values\)\);"
Local $sString = "public static readonly SimpleCommand ReadTemperatureCommand =" & @CRLF & _
" SimpleCommand.Register(ReadTemperatureCommandId, "ReadTemperature", "showtemp.py", "", 5, typeof(TemperatureListCommandResultProcessor), typeof(TemperatureListDeviceValues));" & @CRLF & _
"" & @CRLF & _
" public static readonly SimpleCommand GetDataType1Command =" & @CRLF & _
" SimpleCommand.Register(" & @CRLF & _
" GetDataType1CommandTypeId," & @CRLF & _
" "GetData"," & @CRLF & _
" "HttpClient2.py"," & @CRLF & _
" @"""/data/ajax.txt?CAN=1&HASH=00200403&TYPE=1"" ""GET"" """""," & @CRLF & _
" 5," & @CRLF & _
" typeof(SunwaysSolarInverterDataType1CommandResultProcessor)," & @CRLF & _
" typeof(SunwaysSolarInverterDeviceValues));" & @CRLF & _
"" & @CRLF & _
"public static readonly ArgumentedCommand UpdateAsyncCommandsCommand =" & @CRLF & _
" ArgumentedCommand.Register(" & @CRLF & _
" UpdateAsyncCommandsCommandId," & @CRLF & _
" "UpdateAsyncCommands"," & @CRLF & _
" "UpdateAsyncCommands.py"," & @CRLF & _
" ""," & @CRLF & _
" 5," & @CRLF & _
" UpdateAsyncCommandsCreateArguments," & @CRLF & _
" new[] { typeof(AsynchronousCommand[]) }," & @CRLF & _
" typeof(UpdateAsyncCommandsCommandResultProcessor)," & @CRLF & _
" typeof(GridboxCommunicationObjectValues));" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"public static readonly SimpleDynamicObjectAttribute<bool> AsynchronousCommandsChangedProperty =" & @CRLF & _
" SimpleDynamicObjectAttribute<bool>.Register("AsynchronousCommandsChanged", false, typeof(BusyGridObjectValues), false, false);" & @CRLF & _
"" & @CRLF & _
"public static readonly SimpleDynamicObjectAttribute<string> MailProperty =" & @CRLF & _
" SimpleDynamicObjectAttribute<string>.Register("Mail", typeof(DefaultUserValues));" & @CRLF & _
"" & @CRLF & _
"public static readonly ProtectedSimpleDynamicObjectAttribute<int> PasswordStorageMethodVersionProperty =" & @CRLF & _
" ProtectedSimpleDynamicObjectAttribute<int>.Register("PasswordStorageMethodVersion", 2, typeof(DefaultUserValues));" & @CRLF & _
"" & @CRLF & _
"public static readonly ListSetDynamicObjectAttribute<string> LocalIpNetworksProperty =" & @CRLF & _
" ListSetDynamicObjectAttribute<string>.Register("LocalIpNetworks", typeof(GridboxCommunicationObjectValues));" & @CRLF & _
"" & @CRLF & _
"public static readonly DictionaryDynamicObjectAttribute<Guid, GridObjectTypeContentFilter> ContentFiltersProperty =" & @CRLF & _
" DictionaryDynamicObjectAttribute<Guid, GridObjectTypeContentFilter>.Register("ContentFilters", typeof(DefaultContentFilterValues));" & @CRLF & _
"" & @CRLF & _
" public static readonly StrongGridObjectReference ContentFilterListContentFilterIdProperty =" & @CRLF & _
" StrongGridObjectReference.Register("ContentFilterListContentFilterId", new Guid("ce06d088-1b5e-4cab-98d2-b0fd63bc0d5b"), typeof(ContentFilterValues));" & @CRLF & _
"" & @CRLF & _
" public static readonly GridObjectReference ContentFilterListContentFilterIdProperty =" & @CRLF & _
" GridObjectReference.Register("ContentFilterListContentFilterId", new Guid("ce06d088-1b5e-4cab-98d2-b0fd63bc0d5b"), typeof(ContentFilterValues));" & @CRLF & _
"" & @CRLF & _
" public static readonly GridObjectReference ContentFilterListContentFilterIdProperty =" & @CRLF & _
" GridObjectReference.Register("ContentFilterListContentFilterId", new Guid("ce06d088-1b5e-4cab-98d2-b0fd63bc0d5b"), typeof(ContentFilterValues));" & @CRLF & _
"" & @CRLF & _
"public static readonly GridObjectReferenceList PermissionIdsProperty =" & @CRLF & _
" GridObjectReferenceList.Register("PermissionIds", typeof(DefaultRoleValues));"
Local $sSubst = "GridObjectModel.Register$1Reference$2($3, $4TypeIdString);"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)