$re = '/[a-z0-9.-_]+@[a-z.]+/';
$str = 'a@gmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);