$re = '/([\#]?)GALERY_([0-9]+)([\#]?)/';
$str = '#GALERY_15#';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);