import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TRN.*FRLPD\\s+FRPLY.*\\s*FRLPD\\/([\\w\\s]*).*FRPLY\\/([\\w\\s]*)\\/";
final String string = "1.TORNEAMPLE/ERIC\n"
+ " 2 HHL RT HK1 LYS IN23NOV OUT26NOV PAST\n"
+ " 3 TRN 2C 87 6609 AF 31DEC 1 FRPLY FRLPD HK PAST *\n"
+ " 4 TRN 2C 87 6628 AF 01JAN 4 FRLPD FRPLY HK1 1800 2007\n"
+ " FRLPD/LYON PART DIEU//FRPLY/PARIS GARE LYON /TGD *\n"
+ " 5 MIS 1A HK1 PAR 23MAY-ARCHIVAGES\n"
+ " 6 AP 04.74.07.68.39";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}