$re = '/(?<=\?).*/m';
$str = 'test?asasdad1123x asdae1q32e 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);