const regex = /(^.+\/)([^\.]+)\.([^\.]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.+\\\/)([^\\.]+)\\.([^\\.]+)', '')
const str = `upload/resize_cache/iblock/daa/455_475_075511db9cefbc414a902a46f1b8fae16/5_wIdyXJL7A.jpg`;
const subst = `$1$2XXXXXXXXXXXXL.$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);