$re = '/(\d)(?=(\d{3})+)/';
$str = '60000000.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);