re = /(?> (?P<L> ¬? (?> [A-Z⊥]| \((?R)\) ) )[↔∧∨→])?\g<L>/x
str = 'P
⊥
¬Q
P∧Q
P∨(Q→R)
P∧(Q∧R)
¬P∨¬(Q∧R)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end