# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)((\bfoll[\wá-ú]{4,10})|(\bfoll([aeéoó][nsdr]?(?=[^\wáé])))|(\bfoll(?:([eéaá][ibsrdo][\wáé])))|(folleta))"
test_str = ("follándonoslas, follándonoslos,\n\n"
"follándonosla, follándonoslo, follándomelos, follándotelos, follándomelas, follándotelas, follándooslas, follándooslos, folletinescos, folletinescas, follándoselos, follándoselas, folletinistas,\n\n"
"follándosela, follándoosla, follándoselo, follándotelo, follándotela, folletinesca, folletinesco, folletinista, follándooslo, follándomela, follárnoslos, follándomelo, follárnoslas,\n\n"
"follándolos, follándoles, folletistas, follarÃamos, follándolas, follándonos, follárnoslo, follárselos, follároslos, follármelas, follártelas, follárnosla, follárselas, follártelos, follármelos, follároslas,\n\n"
"folloneras, folletones, follárselo, follársela, follándose, folletista, follártela, follábamos, follártelo, folloneros, follonerÃa, follándola, follándote, folláramos, follándoos, folláremos, follármela, follármelo, follásemos, follárosla, follándome, follároslo, follándolo, follándole, folletines, folladoras, folladores, follarÃais, follaremos, follajerÃa, follasteis,\n\n"
"follonero, folladora, follarlas, follonera, follaréis, follarais, follarÃan, follarlos, follareis, follarnos, follarles, folladnos, follarÃas, folliscas, follabais, folladles, folletero, folladlas, folladlos, follaseis,\n\n"
"folladla, follaban, follaren, follares, follarla, folladas, follador, follabas, follaras, folladlo, follados, follando, follamos, follajes, folladme, folladle, follaran, follarlo, follarme, follones, follarás, folletón, follaste, follases, follasen, follisca, folletÃn, folletos, follarÃa, follonÃa, follarse, follarse, follarte, follarle, follemos, follarán, follaron, follaros,\n\n"
"folléis, folleto, follase, follero, folleta, follaba, follada, follará, follado, follare, follaré, folláis, follaje, follara, follaos,\n\n"
"follen, folles, follad, follar, follan, follas, follón,\n\n"
"follo, folle, follé, folla, folló.")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.