$re = '/insert[\s]+into[\s]+(?<table>.*?)[\s]*\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);/mi';
$str = 'insert into table ( a, b, c ) values ( " insert into values (1,2,3)",1,2.3,"a,b" );
insert into table (ee,bb,cc) values (aa,234,"asj",2.3);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);