re = /(^8|7|\+7)((\d{10})|(\s\(\d{3}\)\s\d{3}\s\d{2}\s\d{2}))/
str = '89043896122'
# Print the match result
str.match(re) do |match|
puts match.to_s
end