re = /http:\/\/^(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])$/
str = '2.10.0.2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end