package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^".”()\d]?(\.{1}\s?)[^".”()\s].`)
var str = `($14.00 at restaurant, $6.40 at home — replacing the lobster with Surimi, seafood that looks like lobster or crab, but made from mostly white fish fillets)
Cover the dough with a cloth and allow to rest while mixing other ingredients.(Reserve 2-4 tbsps of dough for Warm Tomato Dressing below.)Tomato concasseSauté garlic in olive oil until it is transparent.
THE CHEF’S TOUCH “Mmmm... you are my little kumquat. I will prepare this delectable baby cake just for you.” Using “kumquat” as a term of endearment for my wife, Connie, dates back several years.Kumquat season peaks during winter months, just like citrus. (Although many think Kumquats are a citrus fruit, they are classifies in the Fortunella group.) But thanks to a global market, kumquats can be located sporadically throughout the year. I favor small, oval-shaped kumquats, about 80 fruit per pound (fruit size: approximately 1 1/4 inches long and 3/4 inch wide). At the supermarket, kumquats are usually sold by the pint, which weighs about 12 ounces.PVC (polyvinyl chloride) piping can be purchased at almost any hardware store across the land. The PVC used for My Little Kumquat Cakes set us back about 50 cents per 2 1/2-inch-high pipe at our local Ace Hardware store.Instead of spooning the Chocolate Kumquat Mousse onto the cakes inside the PVC pipes, you may find it easier to pipe mousse. Fill a pastry bag, fitted with a large straight tip, with the mousse, then pipe about 1/4 cup of mousse onto each cake. After all the mousse has been dispensed, pick up the baking sheet holding the six PVC pipe, hold it 6 to 8 inches above the work surface, and then allow it to drop. Do this 3 to 4 times, or until the mousse has settled evenly inside the PVC.When my little kumquat and I partake of delicate confections, our thoughts (other than those other thoughts) turn to bubbles. Need I say more?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}