# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?P<head>^tacacs[\s|-]server\shost\s)(?P<ipv4>(\d+\.){3}\d+)(?P<key>\skey\s[0-9]\s\S[a-zA-Z0-9]+\S)?(?P<tail>(.*))"
test_str = ("aaa group server tacacs+ tacacs\n"
" server 172.26.60.235\n"
" server 172.24.248.209\n"
" source-interface mgmt0\n"
"aaa group server tacacs+ TACACS-GROUP\n"
" server 172.26.60.235\n"
" source-interface mgmt0\n"
"aaa group server tacacs+ TACACS-TEST1\n"
" server 172.26.60.235\n"
" server 172.24.248.209\n"
"aaa group server tacacs+ tacacs+group\n"
" source-interface mgmt0\n\n\n"
"ip tacacs source-interface mgmt0\n\n"
"tacacs-server host 172.26.60.235 key 7 \"Foihmr3\" timeout 5\n"
"tacacs-server host 172.24.248.209 key 7 \"Foihmr3\"\n\n\n"
"tacacs server host 172.24.248.209 key 7 \"Foihmr3\"\n\n"
"tacacs-server host 172.26.60.235 timeout 5\n\n"
"tacacs-server host 172.26.60.235\n"
"tacacs-server host 172.24.248.209")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.