#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)"|DECLARE[^]+?Outbound| AS[^]+?DISPLAY NAME|\.\.| ON[^]+?;"
Local $sString = "DECLARE ENTITY FOLDER "Статистика Outbound".."XW_RTM_AGENT_D" AS "XW_RTM_AGENT_D" ENTITY "Statistical Outbound"."XW_RTM_AGENT_D"" & @CRLF & _
" FOLDER ATTRIBUTES (" & @CRLF & _
" "Статистика Outbound".."XW_RTM_AGENT_D"."U_CONTACT_CENTER"," & @CRLF & _
" "Статистика Outbound".."XW_RTM_AGENT_D"."U_MR"," & @CRLF & _
" "Статистика Outbound".."XW_RTM_AGENT_D"."U_GROUP_NAME"," & @CRLF & _
" "Статистика Outbound".."XW_RTM_AGENT_D"."U_NAME"," & @CRLF & _
" "Статистика Outbound".."XW_RTM_AGENT_D"."U_LOGIN"," & @CRLF & _
" "Статистика Outbound".."XW_RTM_AGENT_D"."U_CTI_PIN"," & @CRLF & _
" "Статистика Outbound".."XW_RTM_AGENT_D"."U_ACTIVE_POS_TYPE" )" & @CRLF & _
" DISPLAY NAME "Агенты" ON " & @CRLF & _
" DESCRIPTION {Для корректной работы в отчет с использованием таблицы "Агенты" можно включать поля из таблиц "Предложение", "Признаки", "Абонент", "Взаимодействие" и "Показатели" и нельзя включать поля из таблиц "Предложение (агрегир)" и "Показатели(агрегир)".} " & @CRLF & _
" PRIVILEGES ( READ);" & @CRLF & _
"DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_CONTACT_CENTER" AS "U_CONTACT_CENTER" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_CONTACT_CENTER"" & @CRLF & _
" DISPLAY NAME "Контактный центр агента" ON " & @CRLF & _
" PRIVILEGES ( READ);" & @CRLF & _
"DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_GROUP_NAME" AS "U_GROUP_NAME" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_GROUP_NAME"" & @CRLF & _
" DISPLAY NAME "Группа агента" ON " & @CRLF & _
" PRIVILEGES ( READ);" & @CRLF & _
"DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_LOGIN" AS "U_LOGIN" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_LOGIN"" & @CRLF & _
" DISPLAY NAME "Логин агента Siebel" ON " & @CRLF & _
" PRIVILEGES ( READ);" & @CRLF & _
"DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_MR" AS "U_MR" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_MR"" & @CRLF & _
" DISPLAY NAME "МР агента" ON " & @CRLF & _
" PRIVILEGES ( READ);" & @CRLF & _
"DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_NAME" AS "U_NAME" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_NAME"" & @CRLF & _
" DISPLAY NAME "ФИО агента" ON " & @CRLF & _
" PRIVILEGES ( READ);" & @CRLF & _
"DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_ACTIVE_POS_TYPE" AS "U_ACTIVE_POS_TYPE" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_ACTIVE_POS_TYPE"" & @CRLF & _
" DISPLAY NAME "Тип должности агента" ON " & @CRLF & _
" PRIVILEGES ( READ);" & @CRLF & _
"DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_CTI_PIN" AS "U_CTI_PIN" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_CTI_PIN"" & @CRLF & _
" DISPLAY NAME "Логин агента Genesys" ON " & @CRLF & _
" PRIVILEGES ( READ);" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)