#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d|[1-2]\d|3[01]|99)$"
Local $sString = "0" & @CRLF & _
"2" & @CRLF & _
"01" & @CRLF & _
"10" & @CRLF & _
"15" & @CRLF & _
"23" & @CRLF & _
"31" & @CRLF & _
"32" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")