#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^.0-]|[^.0-][0-9]+|[0])$"
Local $sString = "111111111111111999999999999999990000000000000000333333333333333332" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"2" & @CRLF & _
"0" & @CRLF & _
"-1" & @CRLF & _
"-22" & @CRLF & _
"1.4" & @CRLF & _
"0.1" & @CRLF & _
"0." & @CRLF & _
"0-" & @CRLF & _
"-0" & @CRLF & _
"000.4" & @CRLF & _
"022345" & @CRLF & _
"0" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)