$re = '/^https?:\/\/ihm\.se.*$/m';
$str = 'http://ihm.se
https://ihm.se
http://qvalento.se
https://qvalento.se';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);