$re = '/([^\W_]+[^\s-]*)*/';
$str = 'insert your test string here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);