$re = '/^(?=.*[0-9])(?=.*[A-Za-z])(?=.*[!\x22\#$%&@\'()*+,-./_])[\w!\x22\#$%&@\'()*+,-./]{8,}$/';
$str = 'ddfffr3...';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);