# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[trx[^\]]+.)|(\[\\/trx[^\]]+.)|(<a[^>]+.)|(<img[^>]+.)(<[^>]+.)//g;t' <<< "[trx_columns autoheight=\"no\" indentation=\"yes\" count=\"2\"][trx_column_item width=\"40%\"]
<table>
<tbody>
<tr>
<td width=\"96\">Suprafaţa</td>
<td width=\"96\">39 m²</td>
</tr>
<tr>
<td width=\"96\">Bucătărie</td>
<td width=\"96\">9,2 m²</td>
</tr>
<tr>
<td width=\"96\">Odaie</td>
<td width=\"96\">19.3 m²</td>
</tr>
<tr>
<td width=\"96\">Antreu</td>
<td width=\"96\">4.3 m²</td>
</tr>
<tr>
<td width=\"96\">Bloc sanitar</td>
<td width=\"96\">3.3 m²</td>
</tr>
<tr>
<td width=\"96\">Balcon</td>
<td width=\"96\">2.9 m²</td>
</tr>
<tr>
<td width=\"96\"><strong>Preţ total</strong></td>
<td width=\"96\"><strong>20 475 €</strong></td>
</tr>
</tbody>
</table>
[/trx_column_item][trx_column_item ]<a href=\"http://teatral.md/wp-content/uploads/2015/08/39.jpg\"><img class=\"alignnone size-medium wp-image-4147\" src=\"http://teatral.md/wp-content/uploads/2015/08/39-225x300.jpg\" alt=\"39\" width=\"225\" height=\"300\" /></a>[/trx_column_item][/trx_columns]"