$re = '/[^_\w](sso\b)/';
$str = ' if(s.successProperty) {
this.getSuccess = this.createAccessor(s.successProperty);
em_sso emsso_test \'sso\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);