re = /^[0-9]{2}\.[0-9]{3}\.[0-9]{3}\/[0-9]{4}\-[0-9]{2}/m
str = '25.005.105/0001-64
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end