$re = '/((1|01|001)*(0|00|0?)*)/x';
$str = '01
01
001
0
00
0010010011111111100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);