$re = '/(^|\s)(?!\w*aa\w*)(\w+)/i';
$str = 'net baa cec haw ddd baas bat jackaay lut baa leenat fat faaa tar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);