package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<type>ENNI)(?:::)(?P<ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}|_)?(?:::)(?P<desc>[\w#()/-]*)?`)
var str = `ENNI::10.240.20.10::SHARED_ENNI`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}