package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^A-Z_a-z_[:digit:]]`)
var str = `abcdабвг1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}