$re = '%(\d{1,3}[\,]?\d{1,3)%';
$str = ' CLOSING BALANCE 7100000 29,409.07';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);