package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@(.+?)(?:\s|$)`)
var str = `This is ready for you @wendy @avin @gfat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}