package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((http:\/\/sim\d{1,5}.agni.lindenlab.com:\d{4,5})(\/cap\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}))`)
var str = `http://sim99991.agni.lindenlab.com:12046/cap/171ef743-106d-6a5f-119f-3fe098038d3d`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}