$re = '/^(?:\+[0-9]{1,3}()|[0-9]{6,10}()){2}\1\2$/';
$str = '+3700000000000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);