$re = '/^[a-zA-Zก-๙\.\ ]{1,100}$/u';
$str = 'ดร. ราชวัฒน์ สุขุม';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);