# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"name\s+?z155e4d1dde106c_point_test.+?(?<!meta)data\s*\".+?from\s+([^\s]+?)\""
test_str = ("MAP\n"
" CONFIG \"MS_ERRORFILE\" \"/srv/mapservices/mapfiles/tmp/155e4d1dde106c.log\"\n"
" DEBUG 5\n"
" IMAGETYPE PNG\n"
" SIZE 1600 800\n"
" STATUS ON\n\n"
" WEB\n"
" METADATA\n"
" \"wms_title\" \"Generated_Mapfile\"\n"
" \"wms_onlineresource\" \"http://142.207.151.5/cgi-bin/mapserv?map=/srv/portal/www/Mapservices/mapfiles/TSAZones.map&version=1.0.0&service=wms\"\n"
" \"wms_srs\" \"EPSG:3005 EPSG:4269 EPSG:3857\"\n"
" \"wms_enable_request\" \"*\"\n"
" \"wms_feature_info_mime_type\" \"text/html\"\n"
" END\n"
" QUERYFORMAT text/html\n"
" END\n\n\n"
" PROJECTION\n"
" \"init=epsg:3005\"\n"
" END\n\n"
" OUTPUTFORMAT\n"
" NAME png\n"
" DRIVER AGG/PNG\n"
" MIMETYPE \"image/png\"\n"
" IMAGEMODE RGBA\n"
" EXTENSION \"png\"\n"
" FORMATOPTION \"GAMMA=0.75\"\n"
" TRANSPARENT ON\n"
" END\n"
" LAYER\n"
" DEBUG 5\n"
" NAME z155e4d1dde106c_point_test\n"
" DUMP TRUE\n"
" TEMPLATE \"querytemplate.html\" \n\n"
" PROJECTION\n"
" \"init=epsg:3005\"\n"
" END\n\n"
" METADATA\n"
" \"wms_srs\" \"EPSG:3005\"\n"
" \"title\" \"TSA Zones\"\n"
" \"wms_title\" \"TSA Zones\"\n"
" \"wms_include_items\" \"all\" \n"
" \"gml_include_items\" \"all\" \n"
" END\n\n"
" TYPE POINT\n"
" CONNECTIONTYPE POSTGIS\n"
" CONNECTION \"host=127.0.0.1 dbname=stewardship user=portal_readwrite password=portal_readwrite\"\n"
" DATA \"wkb_geometry from z155e4d1dde106c_point_test\"\n\n"
" \n"
" CLASS\n"
" STYLE\n"
" COLOR 59 189 57 \n"
" OUTLINECOLOR 147 155 48\n"
" OPACITY 100\n"
" END\n"
" END\n"
"END\n"
"LAYER\n"
" DEBUG 5\n"
" NAME z155e4d1dde106c_poly_test1\n"
" DUMP TRUE\n"
" TEMPLATE \"querytemplate.html\" \n\n"
" PROJECTION\n"
" \"init=epsg:3005\"\n"
" END\n\n"
" METADATA\n"
" \"wms_srs\" \"EPSG:3005\"\n"
" \"title\" \"TSA Zones\"\n"
" \"wms_title\" \"TSA Zones\"\n"
" \"wms_include_items\" \"all\" \n"
" \"gml_include_items\" \"all\" \n"
" END\n\n"
" TYPE POLYGON\n"
" CONNECTIONTYPE POSTGIS\n"
" CONNECTION \"host=127.0.0.1 dbname=stewardship user=portal_readwrite password=portal_readwrite\"\n"
" DATA \"wkb_geometry from z155e4d1dde106c_poly_test1\"\n\n"
" \n"
" CLASS\n"
" STYLE\n"
" COLOR 121 71 143 \n"
" OUTLINECOLOR 96 133 94\n"
" OPACITY 100\n"
" END\n"
" END\n"
"END\n"
"END")
matches = re.search(regex, test_str, re.DOTALL | re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.