import Foundation
let pattern = #"[^.?!]*(?<=[.?\s!])was exactly(?=[\s.?!])[^.?!]*[.?!]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
As she did so, a most extraordinary thing happened. The bed-clothes gathered themselves together, leapt up suddenly into a sort of peak, and then jumped headlong over the bottom rail.
It was exactly as if a hand had clutched them in the centre and flung them aside .
Immediately after, .........
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)