re = /^(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|0?[1-9][0-9]?|0?[0-9]?[1-9])(.(25[0-5]|2[0-4][0-9]|[0-1]?[0-9]?[0-9])){2}.(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|0?[1-9][0-9]?|0?[0-9]?[1-9])$/m
str = '256.256.256.256
256.255.255.255
255.256.255.255
255.255.256.255
255.255.255.256
255.255.255.255
255.255.255.0
1.1.1.1
0.1.1.1
1.0.1.1
1.1.0.1
1.0.0.1
1.0.0.0
0.0.0.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end